Backup per email funktioniert nicht mehr

Einen Fehler in efaLive melden

Moderator: klinux

Antworten
rrvhans
Beiträge: 7
Registriert: Sa 21. Dez 2019, 14:41

Backup per email funktioniert nicht mehr

Beitrag von rrvhans » Do 5. Mai 2022, 08:51

Unser EfaLive System läuft schon lange stabil...
efa.version=2.3.0_11
Debian Version 10.12 updates sind aktuell

Der Eintrag
backup create project mailto:xxxemail@gmx.de
(email geändert!)
(Eingetragen unter Automatische Abläufe)
verbunden mit den Provider Einstellungen unter Benachrichtigungen
hat jahrelang bis 14.2.22 funktioniert.
In der gmx Mailbox kam vom gmx Provider am 17.2. diese Nachricht:
eines oder mehrere Ihrer Geräte oder Programme verwendet/n die Verschlüsselungsprotokolle TLS 1.0 und TLS 1.1, um auf unsere GMX E-Mail-Server zuzugreifen.

Zum Zeitpunkt des Email Backup kommt diese Fehlermeldung in efalive:
tail -f /home/efa/efa2/log/efa.log

[04.05.2022 21:15:08] - efaBths - 05340 - WARNING - ERR007 - email-Versand fehlgeschlagen: javax.mail.MessagingException: Could not convert socket to TLS; nested exception is: javax.net.ssl.SSLHandshakeException: No appropriate protocol (protocol is disabled or cipher suites are inappropriate) Could not convert socket to TLS

Ab dem 14.2. verlangt gmx offenbar TLS1.2 oder TLS1.3
Wo muß diese diese Enstellung erfolgen?

Besten dank für Hilfe!
Hans

rrvhans
Beiträge: 7
Registriert: Sa 21. Dez 2019, 14:41

Re: Backup per email funktioniert nicht mehr

Beitrag von rrvhans » So 8. Mai 2022, 21:43

Habe die Ursache des Problems gefunden:
Die Datei
/usr/lib/efa2/program/plugins/javax.mail.jar
muss duch die neue Version javax.mail.jar Version 1.6.2 ersetzt werden:
Diese ist hier zu finden:
https://github.com/javaee/javamail/rele ... x.mail.jar
Danach ist ein reboot fällig

Hinweis: der Fehler besteht auch bei einer Neuistallation von efalive (apt update löst das Problem nicht)

klinux
Beiträge: 192
Registriert: Mi 21. Jul 2010, 11:36

Re: Backup per email funktioniert nicht mehr

Beitrag von klinux » So 8. Mai 2022, 21:59

Hallo,

gut, dass Du das Problem lösen konntest! Alternativ kann man auch ein E-Mail Backup in den efaLive SetupTool einstellen, das funktioniert auch weiterhin.

Ich werde zusehen, dass ich bald eine neue Version bauen kann.

Viele Grüße

Antworten