Sicherung per USB-Stick funktioniert nicht

Einen Fehler in efaLive melden

Moderator: klinux

Antworten
tu36
Beiträge: 10
Registriert: Do 8. Mär 2012, 08:42

Sicherung per USB-Stick funktioniert nicht

Beitrag von tu36 » Mi 5. Nov 2014, 15:03

Moin liebes Forum,

aufgrund eines Einbruchs und der Zerstörung unseres alten EFA habe ich das System als EFALive 2.2 aufgesetzt.
Die Daten aus dem alten EFA (auf XP Basis) konnte ich ohne Probleme einspielen.

Nun zum eigentlichen Problem:

Im EFALive gibt ja das Feature, dass ein Backup erstellt wird, wenn ein USB-Stick eingesteckt wird.
Leider funktioniert dies bei uns nicht.

Ich bekomme die Fehlermeldung:
###############################

Auto backup: Backup failed, error Code: 242 !
View autobackup.log for Details

###############################

aus der autobackup.log

###############################
Mounting /dev/sdb1 to /media/backup
autobackup.sh : Zeile 142: /usr/bin/pmount: Keine Berechtigung
Creating Backup to /media/backup...
Error, specified path does not exist!"
Unmounting /dev/sdb1
autobackup.sh: Zeile /usr/bin/punmount: Keine Berechtigung
Backup failed, error code: 242 !\n\nView autobackup.log for Details
###############################

Nach der Suche im Forum (viewtopic.php?f=23&t=550) habe ich den EFA User repariert.
Danach hat es funktioniert. :-)

Leider nur bis zum nächsten Neustart. :-(

Der Fehler ist nun wieder da und der Button "EFA User Reparieren" ist verschwunden (oder ich kann ihn nicht mehr finden)
Der User EFALive existiert.

Folgendes habe ich außerdem getestet:

Backup aus EFA Bootshaus erstellen (in lokale Dateisystem) geht

USB-Stick mounten (über EFA Konsole "STRG + F9") funktioniert
-> Der Stick wird als /media/KCG gemountet -> KCG ist der Name ist USB-Stick

Backup aus EFA Bootshaus erstellen (auf den gemounteten USB-Stick) geht nicht

Kopieren der Daten als EFA geht nicht
-> "ls -lia" auf den MountPoint und den USB-Stick gibt aus, das nur root im Dateisystem berechtigt ist

Kopieren der Daten als root geht

Getestet wurden verschiedene USB-Sticks mit FAT oder NTFS als Format.

Ich hoffe Ihr könnt mir auf die Sprünge helfen, was bei mir falsch konfiguriert ist.
Liebe Grüße

Torben

Kanu-Club Geesthacht e.V.
EFALive 2.2

klinux
Beiträge: 182
Registriert: Mi 21. Jul 2010, 11:36

Re: Sicherung per USB-Stick funktioniert nicht

Beitrag von klinux » Fr 21. Nov 2014, 19:47

Hallo Torben,

ich habe nun verschiedene Wege ausprobiert, dass zu reproduzieren. Leider ohne Erfolg.
Ist das eine reine efaLive 2.2 Installation? Hast Du das zugrunde liegende Debian System aktualisiert?

Viele Grüße

tu36
Beiträge: 10
Registriert: Do 8. Mär 2012, 08:42

Re: Sicherung per USB-Stick funktioniert nicht

Beitrag von tu36 » Do 27. Nov 2014, 10:31

Hallo klinux,

nein das System hatte keinerlei Updates (außer vllt EFA [über den Updater]) bekommen.

Trotzdem vielen Dank für deine Mühe.

Ich habe erstmal wieder ein Windows installiert (damit kommen dann auch alle zurecht). :-(

Persönlich finde ich EFA-Live richtig gut.

Vielleicht starte ich ja bald einen neuen Versuch :-)

Gruß
Torben
Liebe Grüße

Torben

Kanu-Club Geesthacht e.V.
EFALive 2.2

electria
Beiträge: 126
Registriert: Mi 11. Sep 2013, 10:56
Wohnort: Gelsenkirchen
Kontaktdaten:

Re: Sicherung per USB-Stick funktioniert nicht

Beitrag von electria » Do 27. Nov 2014, 15:34

Hi,

für mich sieht es so aus als fehlten die Gruppenrechte für plugdev. Ich hab nur keine Ahnung warum...

Grüßle
Ralf

Antworten