efaLive auf Raspberry, kein WLAN

Einen Fehler in efaLive melden

Moderator: klinux

Antworten
stefan
Beiträge: 11
Registriert: Mi 21. Apr 2021, 20:21

efaLive auf Raspberry, kein WLAN

Beitrag von stefan » Do 7. Jul 2022, 20:37

Hallo,

ich habe efaLive auf einem Raspberry 3 installiert und bekomme den Pi nicht ins WLAN.
Weder über efaLive Tools noch über raspi-config.

Ich dachte zuerst an ein Hardware Problem, aber ein anderer Raspberry 4 (dessen WLAN unter Raspberry Pi OS funktioniert) verhält sich genauso.

In den efaLive Tools mit Strg-F12 -> Network kann ich auch das WLAN Device auswählen. Nur egal was ich eintrage, nichts verbindet sich.

Vermutlich übersehe ich etwas offensichtliches, weiß jemand einen Tipp oder Anleitung?

Vielen Dank im voraus.
Stefan

stefan
Beiträge: 11
Registriert: Mi 21. Apr 2021, 20:21

Re: efaLive auf Raspberry, kein WLAN

Beitrag von stefan » Mi 7. Sep 2022, 22:14

Ich habe aufgegeben.

Auf einem neuen Raspi 4 tritt das efaLive WLAN Problem ebenso auf.
Mit Raspberry OS und Ubuntu funktioniert sowohl auf dem Raspi 3 als auch Raspi 4 das WLAN wie erwartet.

Ich habe jetzt einen einfachen TP Link Access Point per LAN angehängt - das funktioniert.

Das macht durch den Stromverbrauch den Raspi (und die Mehrarbeit der speziellen Administration, Real Time Clock, SD Karten Anfälligkeiten usw.) etwas überflüssig, weil man dafür auch einen Low Power PC auf x86 Platform laufen lassen kann. Und hat dann dazu einen deutlich leistungsfähigeren Standard PC mit Standard Hardware.

Viele Grüße,
Stefan

klinux
Beiträge: 199
Registriert: Mi 21. Jul 2010, 11:36

Re: efaLive auf Raspberry, kein WLAN

Beitrag von klinux » Fr 16. Sep 2022, 13:46

Hallo Stefan,

ich baue gerade eine neue Version von efaLive zusammen, ich habe mal eine Testversion hochgeladen, damit funktioniert bei mir auf dem Raspi 3 und 4 das WLAN ohne Probleme.
Nach dem Start erscheint (nach einem Neustart) ein kleines Setup-Programm, hier muss u.a. ein neuer Benutzer festgelegt werden. Als Benutzernamen unbedingt 'efa' nutzen, das Passwort kann frei gesetzt werden. Nach dem Setup-Programm wird erneut neu gestartet und dann sollte das übliche Procedere mit der Konfiguration von efa etc folgen.

Hier der Link: https://www.hannay.de/download/efalive/ ... pi.img.zip

Viele Grüße

stefan
Beiträge: 11
Registriert: Mi 21. Apr 2021, 20:21

Re: efaLive auf Raspberry, kein WLAN

Beitrag von stefan » Di 1. Nov 2022, 20:24

Hallo,

vielen Dank, werde ich ausprobieren.

Viele Grüße,
Stefan

stefan
Beiträge: 11
Registriert: Mi 21. Apr 2021, 20:21

Re: efaLive auf Raspberry, kein WLAN

Beitrag von stefan » So 6. Nov 2022, 13:41

Hallo,

getestet habe ich auf einem Raspberry Pi 4 B Rev 1.2.

Initiales Setup:
WLAN verbinden während des initialen Setups:
  • Gast WLAN einer Fritzbox 7590 wird gefunden, WPA Key mit wenigen Sonderzeichen, "Connect to network failed"
  • Hotspot eines iPhone XR wird gefunden, WPA Key einfachst ohne Sonderzeichen, "Connect to network failed"

2. Kaltstart des Raspberry:
  • Setup wird erneut ausgeführt
  • Einstellungen zu Lokalisierung und auch der WPA Key sind vom vorherigen Versuch noch bekannt
  • WLAN Verbindung funktioniert
Obiges heißt auch, ich habe mich nicht vertippt, denn im zweiten Versuch funktioniert die Verbindung ohne Änderung der Parameter.


Änderung des WLANs:
  • In trage den Raspberry jetzt ins Bootshaus, kann dort die WLAN Verbindung aber nicht anpassen auf das dortige Netz.
  • In efaLive Setup -> Netzwerk kann ich WLAN Verbindungen hinzufügen oder löschen. Ich kann mich aber nicht verbinden, zumindest sehe ich nicht wie.
  • Ich habe testweise mein Gast WLAN der Fritzbox in efaLive Setup gelöscht und versucht auf meinen Smartphone Hotspot umschalten, ich schaffe in efaLive Setup nicht mal, dass der Raspberry versucht sich mit dem anderen Netz zu verbinden.
  • Die Konfiguration eines WLAN Netzes in raspi-config scheitert jetzt mit "There was an error running option S1 Wireless LAN". Der Fehler ist neu.
Screenshots anbei.

Viele Grüße,
Stefan
Dateianhänge
IMG_3540.jpeg
Wo ist der Verbinden Button?
IMG_3540.jpeg (78.91 KiB) 597 mal betrachtet
IMG_3539.jpeg
Raspi-Config
IMG_3539.jpeg (78.75 KiB) 597 mal betrachtet

klinux
Beiträge: 199
Registriert: Mi 21. Jul 2010, 11:36

Re: efaLive auf Raspberry, kein WLAN

Beitrag von klinux » Di 31. Jan 2023, 17:01

Hallo Stefan,

ich habe efaLive 2.8.5 hochgeladen (https://www.hannay.de/en/efalive/). Damit funktioniert bei mir das WLAN auf Raspi 3 und 4 problemlos. Zuerst richte ich die Lokalisierung via raspi-config ein und starte neu. Danach konfiguriere ich in efalive-setup eine WLAN Verbindung (siehe Doku). Die Verbindung mit dem WLAN findet dann automatisch statt, da gibt es keinen Knopf.

Viele Grüße

Antworten