efaCLI importiert nicht - behauptet es aber

Einen Fehler in efa2 melden

Moderator: nick

Forumsregeln
Beim Melden eines Fehlers, gib bitte die verwendete efa2-Version und Dein Betriebssystem an, sowie eine genaue Beschreibung der Fehlersituation und ggf. der Fehlermeldungen.
Antworten
mechanical_man
Beiträge: 44
Registriert: Do 9. Sep 2010, 19:05

efaCLI importiert nicht - behauptet es aber

Beitrag von mechanical_man » Sa 12. Jan 2019, 23:30

Hallo Nick,

ich importiere Ruderer aus einer anderen Datenquelle mit efaCLI. Hier bin ich auf ein Problem gestoßen.

So sieht meine Datenquelle "autoimport.csv" aus:

Code: Alles auswählen

FirstName;LastName;Gender;Birthday;Association;StatusId;Email;FreeUse1;FreeUse2;FreeUse3;InvalidFrom
Mueller;Michael;männlich;01.01.2000;EI;8 - Schulrudern;;0123456;;autoimport vom 12.01.2019 - 21:53:56;31.12.2019 23:59:59
Dies ist der import-Befehl:

Code: Alles auswählen

efacli cli@localhost -cmd "persons import -encoding=utf-8 -csvsep=; -csvquote=| -impmode=addupdate -updversion=new /home/efa/efaAufnahme/autoimport.csv"
Nun gibt es 4 Fälle:
1.) Der Ruderer ist und war in der Personen-Liste noch nie erfasst. Er ist komplett neu. Das funktioniert! :D

2.) Der Ruderer ist bekannt und unbegrenzt gültig. Der Datensatz wird aktualisiert. Die Felder werden entsprechend neu geschrieben. Der Gültigkeitszeitraum wird von jetzt bis zum angegebenen Datum gesetzt.

Das ist schon mal nicht ganz verkehrt. Ich habe im efaCLI-Kommando aber "-updversion=new" angegeben. Es soll eine neue Version erstellt werden. Es wird aber nur die vorhandene überschrieben.

3.) Der Ruderer ist bekannt, derzeit gültig, hat aber ein Gültigkeits-Ende in der Zukunft gesetzt.
efa behauptet, dass der Import stattgefunden hat, tut aber nichts. Es wird keine neue Version angelegt und in der vorhandenen Version werden Felder nicht neu geschrieben.

efa meldet trotzdem, dass der import erfolgreich erfolgte:

Code: Alles auswählen

>>efa@efalive:~/efaAufnahme$ efacli cli@localhost -cmd "persons import -encoding=utf-8 -csvsep=; -csvquote=| -impmode=addupdate -updversion=new /home/efa/efaAufnahme/autoimport.csv"

INFO    - EVT001 - PROGRAMMSTART
INFO    - INF002 - Version efa: 2.2.2_39 -- Java: 1.8.0_181 (JVM 25.181-b13) -- OS: Linux 4.9.0-8-686
INFO    - CLI001 - Connecting as cli to localhost:3834 ...
INFO    - CLI001 - Connected.
INFO    - CLI001 - Opening Remote Project Fahrtenbuch ...
INFO    - CLI001 - Remote Project opened.
INFO    - CLI001 - Importing data ...
[b]INFO    - CLI001 - 1 records imported from /home/efa/efaAufnahme/autoimport.csv
[/b]INFO    - COR001 - PROGRAMMENDE
4.) Der Ruderer ist bekannt, aber nicht mehr gültig.

efa macht nichts, meldet aber einen erfolgreichen Import. Verhalten wie unter 3.)

Mache ich irgendwo einen Fehler, oder ist das systematisch?


Dann noch ein kleineres Problem: Ich habe in der csv-Quelle als Datum "31.12.2019 23:59:59". Im efa-Datensatz wird daraus genau ein Tag früher, also "30.12.2019 23:59:59"

Code: Alles auswählen

FirstName;LastName;Gender;Birthday;Association;StatusId;Email;FreeUse1;FreeUse2;FreeUse3;InvalidFrom
Mueller;Michael;männlich;01.01.2000;EI;8 - Schulrudern;;0123456;;autoimport vom 12.01.2019 - 21:53:56;31.12.2019 23:59:59

Und noch eines, auch nicht sehr dramatisch:
Ich hatte zu beginn einen Fehler in der csv-Datei. Das Gültigkeitsende in der csv-Datei war "31.12.yyyy 23:59:59"
Der import von efaCLI lief angeblich problemlos (aber auch wirkungslos).

Code: Alles auswählen

INFO    - EVT001 - PROGRAMMSTART
INFO    - INF002 - Version efa: 2.2.2_39 -- Java: 1.8.0_181 (JVM 25.181-b13) -- OS: Linux 4.9.0-8-686
INFO    - CLI001 - Connecting as cli to localhost:3834 ...
INFO    - CLI001 - Connected.
INFO    - CLI001 - Opening Remote Project RGH_Fahrtenbuch ...
INFO    - CLI001 - Remote Project opened.
INFO    - CLI001 - Importing data ...
[b]INFO    - CLI001 - 1 records imported from /home/efa/efaAufnahme/autoimport.csv
[/b]INFO    - COR001 - PROGRAMMENDE
Ich danke dir für deine Rückmeldung!

Antworten